<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<meta name="msvalidate.01" content="47095B0AD6D12F5591717E3371D268E8" />

	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://moguldom.com/xmlrpc.php" />

	<link rel="preconnect" href="https://fonts.gstatic.com">
	<link href="https://fonts.googleapis.com/css2?family=Roboto:wght@300;400;500;700&display=swap" rel="stylesheet">
	<link href="https://fonts.googleapis.com/css2?family=Roboto+Condensed:wght@300;400;700&display=swap" rel="stylesheet">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;</title>
	<meta name="description" content="Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;" />
	<link rel="canonical" href="https://moguldom.com/406574/where-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;" />
	<meta property="og:description" content="Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;" />
	<meta property="og:url" content="https://moguldom.com/406574/where-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money/" />
	<meta property="og:site_name" content="Moguldom" />
	<meta property="article:published_time" content="2022-05-05T12:00:00+00:00" />
	<meta property="article:modified_time" content="2022-05-05T12:08:07+00:00" />
	<meta property="og:image" content="https://moguldom.com/wp-content/uploads/2022/05/1200-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money-800x420.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="420" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:title" content="Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;" />
	<meta name="twitter:description" content="Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#039;All That Fake Rich Money&#039;" />
	<meta name="twitter:image" content="https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/1200-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?resize=1024%2C576&amp;ssl=1" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Ann Brown" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<!-- / Yoast SEO plugin. -->


<meta name="news_keywords" content="crypto investors, crypto millionaires, hip hop artists, hiphopme, metaverse, rick ross, business, companies, economy, industry, markets" />
<meta name="original-source" content="https://moguldom.com/406574/where-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money/" />
<link rel='dns-prefetch' href='//ffced734d9214ff1804704fae90bb182.js.ubembed.com' />
<link rel='dns-prefetch' href='//c.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//cdn.pubwise.io' />
<link rel='dns-prefetch' href='//securepubads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//tru.am' />
<link rel='dns-prefetch' href='//s3.amazonaws.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Moguldom &raquo; Feed" href="https://moguldom.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Moguldom &raquo; Comments Feed" href="https://moguldom.com/comments/feed/" />
<!-- Preload Fonts -->
<!-- Preload Fonts END -->
<!-- Preload Scripts -->
<!-- Preload Scripts END -->
<!-- Preconnect Origins -->
<!-- Preconnect Origins END -->
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='wp-block-library-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mediaelement-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='contact-form-7-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mashsb-styles-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.8.1' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}[class^="mashicon-"] .text, [class*=" mashicon-"] .text{
    text-indent: -9999px !important;
    line-height: 0px;
    display: block;
    } 
    [class^="mashicon-"] .text:after, [class*=" mashicon-"] .text:after {
        content: "" !important;
        text-indent: 0;
        font-size:13px;
        display: block !important;
    }
    [class^="mashicon-"], [class*=" mashicon-"] {
        width:25%;
        text-align: center !important;
    }
    [class^="mashicon-"] .icon:before, [class*=" mashicon-"] .icon:before {
        float:none;
        margin-right: 0;
    }
    .mashsb-buttons a{
       margin-right: 3px;
       margin-bottom:3px;
       min-width: 0;
       width: 41px;
    }
    .onoffswitch, 
    .onoffswitch-inner:before, 
    .onoffswitch-inner:after 
    .onoffswitch2,
    .onoffswitch2-inner:before, 
    .onoffswitch2-inner:after  {
        margin-right: 0px;
        width: 41px;
        line-height: 41px;
    }
</style>
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='stripe-handler-ng-style-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/stripe-payments/public/assets/css/public.css?ver=2.0.60' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='ppress-frontend-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.11' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='ppress-flatpickr-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.11' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='ppress-select2-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mashfs-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/mashshare-floating-sidebar/assets/css/mashfs.min.css?ver=1.4.0' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mashnet-styles-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/mashshare-networks/assets/css/mashnet.min.css?ver=2.5.0' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mashresp-styles-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/mashshare-responsive/assets/css/mashresp.min.css?ver=2.0.7' type='text/css' media='all' />
<style id='mashresp-styles-inline-css' type='text/css'>

        @media only screen and (max-width: 568px){
            .mashsb-buttons a {
                width: 41px;
            }
        }
        @media only screen and (max-width: 568px){
            [class^="mashicon-"] .text, [class*=" mashicon-"] .text {
                display: none;
            }
        }
</style>
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='mmg-advertising-style-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/inc/mmg-advertising-v3/css/mmg-advertising.css?ver=1650062643' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='swiper-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/css/swiper.css?ver=5.9.3' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='jplayer-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/css/jplayer.blue.monday.css?ver=5.9.3' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='font-genericons-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex/genericons/genericons.min.css?v=3.4&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='font-awesome-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/css/font-awesome.min.css?ver=1569102280' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='ione_ad_styles-css'  href='https://s3.amazonaws.com/ads-videoplayer/rich-media-ads-global.css?ver=5.9.3' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='parent-style-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex/style.min.css?ver=1568936869' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='squarex-style-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/style.min.css?ver=1651632978' type='text/css' media='all' />
<link rel='stylesheet' id='styles-alt-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/style-alt.min.css?ver=1651666989' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='styles-gravity-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/style-gravity.css?ver=1619483009' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' defer src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='mashfs-js-extra'>
/* <![CDATA[ */
var mashfs = {"mobile_width":"460"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/js/swiper.js?ver=5.9.3' id='swiper-js'></script>
<link rel="https://api.w.org/" href="https://moguldom.com/wp-json/" /><link rel="alternate" type="application/json" href="https://moguldom.com/wp-json/wp/v2/posts/406574" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://moguldom.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://moguldom.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://moguldom.com/?p=406574' />
<link rel="alternate" type="application/json+oembed" href="https://moguldom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmoguldom.com%2F406574%2Fwhere-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://moguldom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmoguldom.com%2F406574%2Fwhere-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money%2F&#038;format=xml" />
<meta name="mnet_plugin_version" content="2.10.13" />    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '7b9df07b60'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://moguldom.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><style type='text/css'>img#wpstats{display:none}</style>
		<link rel="manifest" href="/manifest.json">
		<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push( {
		article: 'auto'
	} );
	</script>
		<link rel="apple-touch-icon" sizes="57x57" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-57x57.png">
	<link rel="apple-touch-icon" sizes="60x60" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-60x60.png">
	<link rel="apple-touch-icon" sizes="72x72" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-72x72.png">
	<link rel="apple-touch-icon" sizes="76x76" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-76x76.png">
	<link rel="apple-touch-icon" sizes="114x114" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-114x114.png">
	<link rel="apple-touch-icon" sizes="120x120" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-120x120.png">
	<link rel="apple-touch-icon" sizes="144x144" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-144x144.png">
	<link rel="apple-touch-icon" sizes="152x152" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-152x152.png">
	<link rel="apple-touch-icon" sizes="180x180" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/apple-icon-180x180.png">
	<link rel="icon" type="image/png" sizes="192x192"  href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/android-icon-192x192.png">
	<link rel="icon" type="image/png" sizes="32x32" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/favicon-32x32.png">
	<link rel="icon" type="image/png" sizes="96x96" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/favicon-96x96.png">
	<link rel="icon" type="image/png" sizes="16x16" href="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/favicons/favicon-16x16.png">
	<meta name="msapplication-TileColor" content="#ffffff">
	<meta name="msapplication-TileImage" content="https://moguldom.com/wp-content/themes/squarex-child/images/favicons/ms-icon-144x144.png">
	<meta name="theme-color" content="#ffffff">
			<script>
		(function(i, s, o, g, r, a, m) {
			i['GoogleAnalyticsObject'] = r;
			i[r] = i[r] || function() {
				(i[r].q = i[r].q || []).push(arguments)
			}, i[r].l = 1 * new Date();
		})(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');
		( function() {
			var getCookie = function( name ) {
				var nameEQ = name + '=';
				var ca = document.cookie.split(';');
				for(var i=0;i < ca.length;i++) {
					var c = ca[i];
					while (c.charAt(0)==' ') c = c.substring(1,c.length);
					if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
				}
				return null;
			};

			var createCookie = function(name, value, hours) {
				var expires = '';
				if (hours) {
					var date = new Date();
					date.setTime(date.getTime()+(hours*60*60*1000));
					expires = '; expires='+date.toGMTString();
				}
				var cookie = name+'='+value+expires+'; path=/';
				document.cookie = cookie;
			};

			var getQueryVar = function( name ) {
				var string = window.location.href;
				var vars = {};
				var hash = [];

				if ( string.search(/\?/i) > -1 ) {
					// Store GET params as vars[]
					var hashes = string.slice(string.indexOf('?') + 1).split('&');
					for( var i = 0; i < hashes.length; i++ ) {
						hash = hashes[i].split('=');
						vars[ hash[0] ] = hash[1];
					}
					if ( vars.hasOwnProperty( name ) ) {
						return vars[ name ];
					}
				}

				return null;
			};

			ga( 'create', 'UA-96600828-1', 'auto' );
			ga( 'set', 'dimension5', 'longform' );
ga( 'set', 'dimension6', "abrown" );
ga( 'set', 'dimension7', "2022-05-05 08:00" );

			var utms = {
				'source': getQueryVar( 'utm_source' ),
				'medium': getQueryVar( 'utm_medium' ),
				'campaign': getQueryVar( 'utm_campaign' )
			};
			var cookie = getCookie( 'moguldom_session' );
			if ( null !== cookie ) {
				var cookieUtms = JSON.parse( cookie );

				// if the session had no source and now it does, let's adopt it and let GA work normally.
				if ( ! ( null === cookieUtms.source && utms.source !== null ) ) {
					utms = cookieUtms;
					if ( null !== utms.source ) {
						ga( 'set', 'campaignSource', utms.source );
					}
					if ( null !== utms.medium ) {
						ga( 'set', 'campaignMedium', utms.medium );
					}
					if ( null !== utms.campaign ) {
						ga( 'set', 'campaignName', utms.campaign );
					}
				}
			}
			createCookie( 'moguldom_session', JSON.stringify( utms ), 0.5 );

			ga( 'send', 'pageview' );
		} )();
		</script>
			<script>
	window.dataLayer = window.dataLayer || [];
	function gtag() { dataLayer.push( arguments ); }
	window.addEventListener( 'load', function() {
		var getCookie = function( name ) {
			var nameEQ = name + '=';
			var ca = document.cookie.split(';');
			for(var i=0;i < ca.length;i++) {
				var c = ca[i];
				while (c.charAt(0)==' ') c = c.substring(1,c.length);
				if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
			}
			return null;
		};

		var createCookie = function(name, value, hours) {
			var expires = '';
			if (hours) {
				var date = new Date();
				date.setTime(date.getTime()+(hours*60*60*1000));
				expires = '; expires='+date.toGMTString();
			}
			var cookie = name+'='+value+expires+'; path=/';
			document.cookie = cookie;
		};

		var getQueryVar = function( name ) {
			var string = window.location.href;
			var vars = {};
			var hash = [];

			if ( string.search(/\?/i) > -1 ) {
				// Store GET params as vars[]
				var hashes = string.slice(string.indexOf('?') + 1).split('&');
				for( var i = 0; i < hashes.length; i++ ) {
					hash = hashes[i].split('=');
					vars[ hash[0] ] = hash[1];
				}
				if ( vars.hasOwnProperty( name ) ) {
					return vars[ name ];
				}
			}

			return null;
		};

		gtag( 'js', new Date() );

		gtag( 'set', {
			'custom_map': {
				'dimension1' : 'utm_content_id',
				'dimension2' : 'utm_boost_id',
				'dimension3' : 'utm_widget_id',
				'dimension4' : 'utm_targeting',
				'dimension5' : 'Page Type',
				'dimension6' : 'Author',
				'dimension7' : 'Published Date'
			}
		} );

		var utms = {
			'source': getQueryVar( 'utm_source' ),
			'medium': getQueryVar( 'utm_medium' ),
			'campaign': getQueryVar( 'utm_campaign' )
		};
		var cookie = getCookie( 'moguldom_session_ga4' );
		if ( null !== cookie ) {
			var cookieUtms = JSON.parse( cookie );

			// if the session had no source and now it does, let's adopt it and let GA work normally.
			if ( ! ( null === cookieUtms.source && utms.source !== null ) ) {
				utms = cookieUtms;
				if ( null !== utms.source ) {
					gtag( 'set', 'campaignSource', utms.source );
				}
				if ( null !== utms.medium ) {
					gtag( 'set', 'campaignMedium', utms.medium );
				}
				if ( null !== utms.campaign ) {
					gtag( 'set', 'campaignName', utms.campaign );
				}
			}
		}
		createCookie( 'moguldom_session_ga4', JSON.stringify( utms ), 0.5 );

		var ga4Dimensions = {"Page Type":"longform","Author":"abrown","Published Date":"2022-05-05 08:00"};

		gtag( 'config', 'G-B9QQ4NMGN5', ga4Dimensions );
	} );
	</script>
	<script>
	function offcanvasMuscle() {
	    var triggers = document.getElementsByClassName('offcanvas-trigger');

	    for (var i = 0; i < triggers.length; i++) {
	        triggers[i].addEventListener("click", function() {
	            var targetMenu = this.getAttribute('offcanvas-menu');
	            toggleOffcanvasMuscleMenu(targetMenu);
	        });
	    }
	}

	function toggleOffcanvasMuscleMenu(menuId) {
	    var myMenu = document.getElementById(menuId);

	    myMenu.classList.toggle('open');

	    var siteWrap = document.getElementsByClassName('site-wrap')[0];
	    siteWrap.classList.toggle('open');

	    if (myMenu.classList.contains('left'))
	        siteWrap.classList.toggle('left');

	    if (myMenu.classList.contains('right'))
	        siteWrap.classList.toggle('right');
	}
</script>

<style type="text/css">
body { color: #404040; }
.entry-header p { color: #333333; }
.blog-widget .textwidget p:after, .no-sidebar .format-standard h1.page-title:after { background-color: #333333; }
button,
html input[type="button"],
input[type="reset"],
input[type="submit"] { background: #000; }
button:hover,
html input[type="button"]:hover,
input[type="reset"]:hover,
input[type="submit"]:hover { background: #000; }
        .site-content a, #home-tagline h1, cite { color: #000; }
        #content a:hover, .site-content a:hover, .site-footer a:hover { color: #000; }

        .main-navigation { background: #FFF; }



.main-navigation li a { color: #2d2d2d; }
.main-navigation li a:hover  { color: #CCC; }
.main-navigation, .footer-border { border-top-color: #333; }
.page-header, .single .entry-content, #colophon.wrap { border-color: #DDD; }


.site-content .entry-meta, .comment-metadata, .comments-area .reply:before, label { color: #aaaaaa; }
.site-footer, .site-footer a { color: #333; }
.site-footer { background: #FFF; }
	.nav-menu li:hover,
	.nav-menu li.sfHover,
	.nav-menuu a:focus,
	.nav-menu a:hover, 
	.nav-menu a:active,
.main-navigation li ul li a:hover  { background: #F2F2F2; }
	.nav-menu .current_page_item a,
	.nav-menu .current-post-ancestor a,
	.nav-menu .current-menu-item a { background: #ffffff; }
    </style>
    		<!-- Custom DFP Ads v3.0 -->
		<script type="text/javascript">
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		var pbjs = pbjs || {};
		pbjs.que = pbjs.que || [];
		!function(a9,a,p){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};}("apstag",window,document);
		</script>
		
<!-- Facebook Pixel Code -->
<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>
  fbq('init', '2650092425307174', {}, {
    "agent": "wordpress-5.9.3-3.0.6"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>
<!-- Facebook Pixel Code -->
<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=2650092425307174&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<link rel="amphtml" href="https://moguldom.com/406574/where-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money/amp/">		<style type="text/css" id="wp-custom-css">
			.taxonomy-description { text-align: left !important; }

figure img {
	display: block;
	margin: auto;
}

@media only screen and (max-width: 1199px) {
	.tile--alt {
			width: 100%;
			border-bottom: 0;
			padding: 20px;
	}
}		</style>
		
	<!-- OneTrust Cookies Consent Notice start for moguldom.com -->

	<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="a9e3b3b7-df68-4995-8a0b-058f17ffb99d" ></script>
	<script type="text/javascript">
	function OptanonWrapper() { }
	</script>
	<!-- OneTrust Cookies Consent Notice end for moguldom.com -->
</head>
<body class="post-template-default single single-post postid-406574 single-format-standard group-blog">
	
	<header class="header">
	<div class="shell header__shell">
		<div class="header__logo">
			<a href="https://moguldom.com/" class="logo">
				<img src="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/logo.png" alt="Moguldom Logo">
			</a>
		</div><!-- /.header__logo -->

		<div class="header__menu js-menu">
			<div class="header__nav">
				<nav class="nav nav--mobile"><ul id="menu-primary" class="menu"><li id="menu-item-142856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-142856"><a href="https://moguldom.com/category/politics/">Politics</a></li>
<li id="menu-item-350234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350234"><a href="https://moguldom.com/category/kos/">KOS</a></li>
<li id="menu-item-143189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143189"><a href="https://moguldom.com/category/crypto/">Crypto</a></li>
<li id="menu-item-226356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-226356"><a href="https://moguldom.com/category/reparations/">Reparations</a></li>
<li id="menu-item-166459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166459"><a href="https://moguldom.com/category/markets/">Markets</a></li>
<li id="menu-item-275912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-275912"><a href="https://moguldom.com/category/gold">Gold</a></li>
<li id="menu-item-143184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143184"><a href="https://moguldom.com/category/tech/">Tech</a></li>
<li id="menu-item-143146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143146"><a href="https://moguldom.com/ghogh/">Podcast</a></li>
<li id="menu-item-157807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-157807"><a href="#">More</a>
<ul class="sub-menu">
	<li id="menu-item-143183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143183"><a href="https://moguldom.com/category/hollywood/">Entertainment</a></li>
	<li id="menu-item-143353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143353"><a href="https://moguldom.com/category/afk-insider/">Africa</a></li>
	<li id="menu-item-157810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157810"><a href="https://moguldom.com/about/">About</a></li>
	<li id="menu-item-157808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157808"><a href="https://moguldom.com/contact/">Contact</a></li>
	<li id="menu-item-157809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157809"><a href="https://moguldom.com/privacy-2/">Privacy Policy</a></li>
</ul>
</li>
</ul></nav>			</div><!-- /.header__nav -->

			<div class="header__aside">
				<div class="header__search">
					<a href="#" class="js-open">
						<i class="fa fa-search" aria-hidden="true"></i>
					</a>
				</div><!-- /.header__search -->

				<div class="header__actions">
					<a href="https://moguldom.com/newsletter" class="btn-alt btn-alt--mobile">Subscribe</a>
				</div><!-- /.header__actions -->
			</div><!-- /.header__aside -->
		</div><!-- /.header__menu -->

		<div class="header__search header__search--mobile js-search">
			<a href="#" class="js-open">
				<i class="fa fa-search" aria-hidden="true"></i>
			</a>
		</div><!-- /.header__search -->

		<div class="menu-toggle-alt js-toggle">
			<a href="#" class="btn-alt">
				<i class="fa fa-ellipsis-h" aria-hidden="true"></i>

				<span>Menu</span>
			</a>
		</div><!-- /.menu-toggle -->
	</div><!-- /.shell -->

	<div class="header__form js-form">
		<div class="shell">
			<form role="search" method="get" class="search-form" action="https://moguldom.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search" value="" name="s">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
		</div><!-- /.shell -->
	</div><!-- /.header__form -->
</header><!-- /.header -->
	<div class="wrapper">
		<div class="wrapper__inner">

		<div class="section-article">
			<div class="section__back"></div><!-- /.section__back -->

			<div class="section__title-primary section__title--mobile">
				<h1>Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#8216;All That Fake Rich Money&#8217;</h1>
			</div><!-- /.section__title-/-mobile -->

			<div class="shell shell--alt section__shell">
				<div class="section__wrapper">
					<div class="section__entry">
						<div class="section__ad leaderboard-container">
							<div class="ad-container">
								<!-- Ad Tag found but NOT ACTIVE | position:leaderboard | category:ros -->
							</div>
						</div><!-- /.section__ad -->
						<div id="leaderboard-size-helper"></div>

						<div class="section__inner">
							<div class="section__head">
								<div class="section__title-primary">
									<h1>Where You At? Rick Ross Tells Crypto And Metaverse Investors To Show Him &#8216;All That Fake Rich Money&#8217;</h1>
								</div><!-- /.section__title -->

																	<div class="section__image">
										<img width="915" height="540" src="https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?fit=915%2C540&amp;ssl=1" class="attachment-1000x0 size-1000x0 wp-post-image" alt="ross" srcset="https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?w=915&amp;ssl=1 915w, https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?resize=593%2C350&amp;ssl=1 593w, https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?resize=768%2C453&amp;ssl=1 768w, https://i0.wp.com/moguldom.com/wp-content/uploads/2022/05/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg?resize=800%2C472&amp;ssl=1 800w" sizes="(max-width: 915px) 100vw, 915px" />									</div><!-- /.section__image -->

									<div class="section__caption">
										<p>Photo: Rick Ross #shotbydrew for The Come Up Show, Sound Academy, Toronto, Dec. 22, 2011</p>
									</div><!-- /.section__caption -->
																</div><!-- /.section__head -->

							<div class="section__body">
								<div class="section__author ">
	<div class="authors">
					<div class="author author__info">
									<div class="author__image">
						<img alt='' src='https://secure.gravatar.com/avatar/0a331091d32d21ae1aa40e5e7dc8b8a9?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0a331091d32d21ae1aa40e5e7dc8b8a9?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>					</div><!-- /.author__image -->
					
				<div class="author__name">
					<p>
						Written by Ann Brown					</p>

					<p>May 05, 2022</p>
				</div><!-- /.author__name -->
			</div><!-- /.author__info -->
				</div>
	<a class="author-btn" href="https://moguldom.com/newsletter">Subscribe</a>
	<div class="author__socials">
		<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-count mash-small" style="float:left;"><div class="counts mashsbcount">77</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><a class="mashicon-facebook mash-small mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmoguldom.com%2F406574%2Fwhere-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money%2F%3Futm_source%3Dsharebuttons%26utm_medium%3Dfacebook%26utm_campaign%3Dmashshare" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-small mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Where%20You%20At%3F%20Rick%20Ross%20Tells%20Crypto%20And%20Metaverse%20Investors%20To%20Show%20Him%20%E2%80%98All%20That%20Fake%20Rich%20Money%E2%80%99&url=https://moguldom.com/?p=406574" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch2 mash-small mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.8.1-->	</div><!-- /.author__socials -->
</div><!-- /.section__author -->

								<div class="section__content">
									<p>Not a day seems to go by lately without a news story about a crypto investor claiming to rake in millions of dollars but hip-hop mogul Rick Ross isn&rsquo;t buying it.</p>



<p>Ross posted a video on his Instagram story on May 2 in which he demanded to see receipts. He said he doesn&rsquo;t believe that&nbsp;<a href="https://www.xxlmag.com/history-hip-hop-connection-cryptocurrency/" target="_blank" rel="noreferrer noopener">investors in cryptocurrency</a>&nbsp;are actually getting rich, and he wants to see proof.</p>



<p>In the post, he called out&nbsp;<a href="https://www.xxlmag.com/nipsey-hussle-guide-bitcoin-cryptocurrency/" target="_blank" rel="noreferrer noopener">crypto gurus</a>&nbsp;who claim they are making big money in the metaverse,&nbsp;<a href="https://www.xxlmag.com/rick-ross-crypto-investors-rich/" target="_blank" rel="noreferrer noopener">XXL</a>&nbsp;reported.</p><div class="longform-wrapper "><!-- Ad Tag: ad-tag-longform-desktop -->
<div id="ad-tag-longform-desktop" class="cda-ad" data-adunit="/1110987598/8752772" data-adsizes='{"desktop":[[1,1],[300,600],[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting="[]" data-skip-lazyload="false"></div></div>



<p></p>



<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Rick Ross wants crypto investors to prove they&rsquo;re making money &#128557; <a href="https://t.co/pgn4KqBGqa">pic.twitter.com/pgn4KqBGqa</a></p>&mdash; Hot Freestyle (@HotFreestyle) <a href="https://twitter.com/HotFreestyle/status/1521189995188391936?ref_src=twsrc%5Etfw">May 2, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></figure><p></p>



<p>&ldquo;That&rsquo;s the thing about the boss,&nbsp;<a href="https://www.xxlmag.com/tyler-the-creator-nfts/" target="_blank" rel="noreferrer noopener">the metaverse</a>, crypto, y&rsquo;all getting so much money, where you at?&rdquo; he asked. &ldquo;Show us. And I don&rsquo;t mean, &lsquo;Oh, I&rsquo;m trying to get money.&rsquo; Man, I got a lot of money. I don&rsquo;t need that fake money.&rdquo;</p>



<p>He added, &ldquo;Show my homies what the metaverse is about,&rdquo; he said. &ldquo;One of y&rsquo;all big crypto dudes, gurus, crypto picture-takers, step up and say, &lsquo;This is what we are going to do, Rozay.&rsquo; Where ya at?&rdquo;</p>



<p>Ross, who is worth an estimated $45&nbsp;<a href="https://www.celebritynetworth.com/richest-celebrities/richest-rappers/rick-ross-net-worth/" target="_blank" rel="noreferrer noopener">million</a>, went on. &ldquo;All that fake-rich money, where&rsquo;s it at?&rdquo; he asked. &ldquo;Educate us. I know some rich homies who&rsquo;s getting money&mdash;Bitcoin Rodney&mdash;yeah, that boy getting real money, but, come on, man, bring that to the Renzel-verse, man.&rdquo;</p><div class="longform-wrapper"><!-- Ad Tag: ad-tag-longform-desktop2 -->
<div id="ad-tag-longform-desktop2" class="cda-ad" data-adunit="/1110987598/2nd_OCT_21_2nd_Position_Within_Content_Desktop" data-adsizes='{"desktop":[[300,600],[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting="[]" data-skip-lazyload="false"></div></div>



<p></p>


<p style="text-align: center;"><iframe loading="lazy" src="https://playlist.megaphone.fm?e=NUB8230306225" width="100%" height="200" frameborder="0" scrolling="no"></iframe></p>
<p style="text-align: center;"><em>Listen to GHOGH with <strong>Jamarlin Martin</strong> | Episode 74: Jamarlin Martin Jamarlin returns for a new season of the GHOGH podcast to discuss Bitcoin, bubbles, and Biden. He talks about the risk factors for Bitcoin as an investment asset including origin risk, speculative market structure, regulatory, and environment. Are broader financial markets in a massive speculative bubble?</em></p>


<p></p>



<p>Ross has made his wealth through his recording career and investments He has Maybach Music Group record label, 25 Wingstop fast-food eateries, partnerships with major spirit and food brands, and a stake in the webcast music contest series VERZUZ,&nbsp;<a href="https://www.blackenterprise.com/boss-moves-rick-ross-bought-a-1m-atlanta-home-just-to-drive-by-it/" target="_blank" rel="noreferrer noopener">Black Enterprise</a>&nbsp;reported.&nbsp; &nbsp;&nbsp;</p>



<p>He has one of the most successful recording careers in hip hop, selling millions of records. Of his Recording Industry Association of America (RIAA) <a href="https://www.complex.com/music/rick-ross-gets-nine-new-riaa-certifications" target="_blank" rel="noreferrer noopener">certifications</a>, four are gold&mdash;&ldquo;Thug Cry,&rdquo; &ldquo;Push It,&rdquo; &ldquo;Sorry,&rdquo; and &ldquo;9 Piece&rdquo;&mdash; and five are platinum: &ldquo;Aston Martin Music,&rdquo; &ldquo;Diced Pineapples,&rdquo; &ldquo;B.M.F. (Blowin&rsquo; Money Fast),&rdquo; &ldquo;Stay Schemin&rsquo;,&rdquo; and &ldquo;Hustlin&rsquo;.&rdquo;</p><div class="longform-wrapper"><!-- Ad Tag: ad-tag-longform-desktop3 -->
<div id="ad-tag-longform-desktop3" class="cda-ad" data-adunit="/1110987598/3rd_Position_Within_Content_Desktop" data-adsizes='{"desktop":[[300,600],[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting="[]" data-skip-lazyload="false"></div></div>



<p>And in 2020, Ross acquired&nbsp;<a href="https://moguldom.com/313713/rick-ross-acquires-87-acres-in-atl-for-1-million/" target="_blank" rel="noreferrer noopener">87 acres of land&nbsp;</a>in Atlanta for $1 million. This was in addition to his massive mansion, also in Atlanta, and other real estate holdings.</p>



<p><em>Photo: Rick Ross <a href="http://www.shotbydrew.com/" target="_blank" rel="noreferrer noopener">#shotbydrew</a> for <a href="https://www.flickr.com/photos/thecomeupshow/" target="_blank" rel="noreferrer noopener">The Come Up Show</a>, Sound Academy, Toronto, Dec. 22, 2011</em><em><a href="https://www.flickr.com/photos/thecomeupshow/" target="_blank" rel="noreferrer noopener">https://www.flickr.com/photos/thecomeupshow/</a><br><a href="http://www.shotbydrew.com/" target="_blank" rel="noreferrer noopener">http://www.shotbydrew.com/</a><br><a href="https://creativecommons.org/licenses/by-nd/2.0/" target="_blank" rel="noreferrer noopener">https://creativecommons.org/licenses/by-nd/2.0/</a></em></p>

									
									<div class="page-links"></div>
								</div><!-- /.section__content -->
							</div><!-- /.section__body -->

							<div class="section__after_content">
								<div class="asp_product_buy_button"><div class="asp-processing-cont" style="display:none;"><span class="asp-processing">Processing <i>.</i><i>.</i><i>.</i></span></div><form id = 'asp_ng_form_06273beded3be6' class='asp-stripe-form' action = '' METHOD = 'POST'> <input type='hidden' name='asp_product_id' value='372280' /><div class="asp-child-hidden-fields" style="display: none !important;"></div></form><div id="asp-all-buttons-container-06273beded3be6" class="asp_all_buttons_container"><div class="asp_product_buy_btn_container"><button id="asp_ng_button_06273beded3be6" type="submit" class="contrib_btn"><span>Contribute Now</span></button></div><noscript>Stripe Payments requires Javascript to be supported by the browser in order to operate.</noscript></div><div id="asp-btn-spinner-container-06273beded3be6" class="asp-btn-spinner-container" style="display: none !important"><div class="asp-btn-spinner"><div></div><div></div><div></div><div></div></div></div><script>var asp_data_06273beded3be6 = {"is_live":true,"product_id":"372280","iframe_url":"https:\/\/moguldom.com\/asp-payment-box\/?product_id=372280","button_key":"5bce4cd7fcad39013e84273d97ebc27f","item_price":0,"quantity":1,"custom_quantity":"","description":"","descrGenerated":false,"shipping":0,"tax":0,"image":"","currency":"USD","currency_variable":"","locale":"en","name":"Contribute to The Moguldom Nation","url":"","amount":0,"billingAddress":false,"shippingAddress":false,"customer_email":"","uniq_id":"06273beded3be6","variable":true,"zeroCents":["JPY","MGA","VND","KRW"],"addonHooks":[],"button_text":"Contribute Now","out_of_stock":false,"stock_control_enabled":false,"stock_items":0,"currencyFormat":{"c":2,"d":".","t":",","s":"$","pos":"left"},"displayStr":{"tax":"%s (tax)","ship":"%s (shipping)"},"thankyou_page_url":"","show_custom_amount_input":false};if(typeof jQuery!=="undefined") {jQuery(document).ready(function() {new stripeHandlerNG(asp_data_06273beded3be6);});} else { if (typeof wpaspInitOnDocReady==="undefined") {var wpaspInitOnDocReady=[];} wpaspInitOnDocReady.push(asp_data_06273beded3be6);}</script></div>								<div class="author author--alt">
									<div class="author__socials">
										<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-count mash-small" style="float:left;"><div class="counts mashsbcount">77</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><a class="mashicon-facebook mash-small mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmoguldom.com%2F406574%2Fwhere-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money%2F%3Futm_source%3Dsharebuttons%26utm_medium%3Dfacebook%26utm_campaign%3Dmashshare" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-small mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Where%20You%20At%3F%20Rick%20Ross%20Tells%20Crypto%20And%20Metaverse%20Investors%20To%20Show%20Him%20%E2%80%98All%20That%20Fake%20Rich%20Money%E2%80%99&url=https://moguldom.com/?p=406574" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch2 mash-small mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.8.1-->									</div><!-- /.author__socials -->
								</div><!-- /.author -->
							</div><!-- /.section__after_content -->
						</div><!-- /.section__inner -->

						<div class="section__ad">
							<!-- Ad Tag NOT FOUND | position:below_social | category:ros -->
						</div><!-- /.section__ad -->

						<div class="section__main">
							<div class="articles">
								<div class="articles__items">
									<!-- Showing sidebar: article-below-content | has widgets --><aside id="moguldom_advertisement_v2-9" class="widget widget_moguldom_advertisement_v2">		<div class="ad-container">
			<!-- Ad Tag: ad-tag-below_post -->
<div id="ad-tag-below_post" class="cda-ad" data-adunit="/1110987598/55555671" data-adsizes='{"desktop":[[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting='[]'></div>		</div>
		</aside><aside id="custom_html-33" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({
mode: 'alternating-thumbnails-a',
container: 'taboola-below-article-thumbnails',
placement: 'Below Article Thumbnails',
target_type: 'mix'
});
</script></div></aside>								</div><!-- /.articles__items -->
							</div><!-- /.articles -->
						</div><!-- /.section__main -->
					</div><!-- /.section__entry -->

					<div class="section__aside">
						<div>
							
<!-- Sidebar HOOK -->
<!-- Showing sidebar: sidebar-2 | has widgets --><aside id="moguldom_advertisement_v2-8" class="widget widget_moguldom_advertisement_v2">		<div class="ad-container">
			<!-- Ad Tag: ad-tag-sidebar -->
<div id="ad-tag-sidebar" class="cda-ad" data-adunit="/1110987598/10456987123" data-adsizes='{"desktop":[[300,600],[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting='[]'></div>		</div>
		</aside><aside id="text-2" class="widget widget_text">			<div class="textwidget"><stock-market-widget type="ticker-quotes" template="background" color="#22292F" assets="^SPX,ETH-USD,GLD,DX-Y.NYB,BTC-USD" animation="true" api="yf" speed="50" direction="left" pause="true"></stock-market-widget>
</div>
		</aside>						</div>
					</div><!-- /.section__aside -->
				</div><!-- /.section__wrapper -->
			</div><!-- /.shell section__shell -->
		</div><!-- /.section-article -->
		

		</div><!-- /.wrapper__inner -->
	</div><!-- /.wrapper -->

	<footer class="footer">
	<div class="shell footer__shell">
		<div class="footer__col">
			<div class="footer__logo">
				<a href="https://moguldom.com/" class="logo">
					<img src="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/themes/squarex-child/images/logo.png')" alt="">
				</a>
			</div><!-- /.footer__logo -->

			<div class="footer__copy">
				<p>&copy; 2022 The Moguldom Nation. All Rights Reserved.</p>
				<p><a href="#" class="ot-sdk-show-settings" style="color:white;">Do Not Sell My Personal Information</a></p>
			</div><!-- /.footer__copy -->
		</div><!-- /.footer__col -->

		<div class="footer__col">
			<div class="footer__copy footer__copy--mobile">
				<p>&copy; 2022 The Moguldom Nation. All Rights Reserved.</p>
				<p><a href="#" class="ot-sdk-show-settings" style="color:white;">Do Not Sell My Personal Information</a></p>
			</div><!-- /.footer__copy footer__copy-/-mobile -->

			<div class="footer__menu">
				<div class="footer__nav">
									</div><!-- /.footer__nav -->

				<div class="footer__actions">
					<a href="https://moguldom.com/newsletter" class="btn-alt">Subscribe</a>
				</div><!-- /.footer__actions -->
			</div><!-- /.footer__menu -->

			<div class="footer__socials">
							</div><!-- /.footer__socials -->
		</div><!-- /.footer__col -->
	</div><!-- /.shell -->
</footer><!-- /.footer -->
	<div class="loading-screen" style="z-index: 9999999999999999999999999999999">
		<div class="spinner"></div><!-- /.spinner -->
	</div><!-- /.loadins-screen -->

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><aside id="mashfs-main" class="mashfs-hide mashfs-left" style="background-color: transparent; margin-left:0px; margin-right:0px;"><div class="mashfs-buttons"></div></aside>	<!-- Global site tag (gtag.js) - Google AdWords: 856272043 -->
	<script>
		window.dataLayer = window.dataLayer || [];
		function gtag() {
			dataLayer.push( arguments );
		}

		gtag( 'config', 'AW-856272043' );

		setTimeout( function() {
			gtag( 'event', 'conversion', {
				'send_to': 'AW-856272043/huhxCN7DxYgBEKvZppgD'
			} );
		}, 5 * 60 * 1000 );

		setTimeout( function() {
			gtag( 'event', 'conversion', {
				'send_to': 'AW-856272043/EQJkCO_wtogBEKvZppgD'
			} );
		}, 10 * 60 * 1000 );
	</script>
		<script>
	(adsbygoogle = window.adsbygoogle || []).push({
		google_ad_client: "ca-pub-5036332969457302",
		enable_page_level_ads: true
	});
	</script>
		<script data-obct type="text/javascript">
	/** DO NOT MODIFY THIS CODE**/
	!function(_window, _document) {
		var OB_ADV_ID='00c59b309ef666c2b1ca09dc1e4acb6935';
		if (_window.obApi) {var toArray = function(object) {return Object.prototype.toString.call(object) === '[object Array]' ? object : [object];};_window.obApi.marketerId = toArray(_window.obApi.marketerId).concat(toArray(OB_ADV_ID));return;}
		var api = _window.obApi = function() {api.dispatch ? api.dispatch.apply(api, arguments) : api.queue.push(arguments);};api.version = '1.1';api.loaded = true;api.marketerId = OB_ADV_ID;api.queue = [];
	}(window, document);
	obApi('track', 'PAGE_VIEW');
	</script>
	<!-- Ad Tag: ad-tag-undertone -->
<div id="ad-tag-undertone" class="cda-ad" data-adunit="/1110987598/Undertone_pg" data-adsizes='{"desktop":[[1,1]],"mobile":[[1,1]]}' data-adoutofpage="" data-targeting='[]'></div>	<script type="text/javascript">
		window.addEventListener( 'load', function() {
			var s = document.createElement( 'script' );
			s.src = '//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js';
			s.async = true;
			s.onload = function() {
				window.cookieconsent.initialise( {
					"palette": {
						"popup": {
							"background": "#f5f5f5",
							"text": "#000000"
						},
						"button": {
							"background": "#000000"
						}
					},
					"theme": "edgeless",
					"position": "bottom-right"
				} );
			};
			document.body.appendChild( s );
			// Defer loading of cookieconsent css.
			var link = document.createElement( 'link' );
			link.rel = 'stylesheet';
			link.href = '//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css';
			link.type = 'text/css';
			var firstLinkNode = document.getElementsByTagName( 'link' )[0];
			firstLinkNode.parentNode.insertBefore( link, firstLinkNode );
		} );
	</script>
		<!-- Taboola Pixel Code -->
	<script type='text/javascript'>
	window._tfa = window._tfa || [];
	window._tfa.push( {
		notify: 'event',
		name: 'page_view',
		id: 1206804
	} );
	</script>
	<!-- End of Taboola Pixel Code -->
		<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push( {
		flush: true
	} );
	</script>
			<!-- Facebook Pixel Code -->
		<script type='text/javascript'>
			!function(f,b,e,v,n,t,s){
				if(f.fbq)return;n=f.fbq=function(){n.callMethod?
				n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
				n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=1;
				t.src=v;s=b.getElementsByTagName(e)[0];
				window.addEventListener( 'load', function() {
					setTimeout( function() {
						s.parentNode.insertBefore(t,s);
						console.log( 'inject fb' );
					}, 2000 );
				} );
			}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
		</script>
		<!-- End Facebook Pixel Code -->
		<script>
			fbq( 'init', "124834173042878" );
			fbq( 'track', 'PageView' );
		</script>
		<noscript>
			<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=124834173042878&ev=PageView&noscript=1"/>
		</noscript>
				<!-- Begin comScore Tag -->
		<script>
		var _comscore = _comscore || [];
		_comscore.push({ c1: "2", c2: "25292127", c3: "", c4: document.location.href });

		(function() {
		var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=25292127&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<!-- Twitter universal website tag code -->
		<script>
		!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
		},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js')
		e.addEventListener( 'load', function() {
			setTimeout( function() {
				document.body.appendChild(u);
			}, 500 );
		} );
	}(window,document,'script');
		// Insert Twitter Pixel ID and Standard Event data below
		twq( 'init', 'nxdlm' );
		twq( 'track', 'PageView' );
		</script>
		<!-- End Twitter universal website tag code -->
			<!-- Twitter single-event website tag code -->
	<script>
		window.addEventListener( 'load', function() {
			var s = document.createElement( 'script' );
			s.src = '//platform.twitter.com/oct.js';
			s.async = true;
			s.onload = function() {
				twttr.conversion.trackPid( 'nxl6a', { tw_sale_amount: 0, tw_order_quantity: 0 } );
				twttr.conversion.trackPid( 'o00b9', { tw_sale_amount: 0, tw_order_quantity: 0 } );
			};
			document.body.appendChild( s );
		} );
	</script>
	<noscript>
		<img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=nxl6a&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
		<img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=nxl6a&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
		<img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=o00b9&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
		<img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=o00b9&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
	</noscript>
	<!-- End Twitter single-event website tag code -->
			<!-- LinkedIn tracking pixel -->
		<script type="text/javascript">
		_linkedin_data_partner_id = "43946";
		</script>
		<!-- End LinkedIn tracking pixel -->
				<script>
			window.addEventListener( 'load', function() {
				var img = document.createElement( 'img' );
				img.src = '//trends.revcontent.com/conv.php?t=WmAWL3Kd3yUBSey4XE1wmo4Y1zaL9qtjK5%2F3UMn6L2LwHb9ugOQrTUtmIofyb%2Bsj';
				document.body.appendChild( img );
			} );
		</script>
				<script>
			window.assertive = {
				debug: false,
				entityId: '8TbKqvot9rNud3j6Q',
				analytics: {
					sampleRate: 1,
					custom: {
						layout: null,
						userState: null,
						custom_1: null,
						custom_2: null,
						custom_3: null,
						custom_4: null,
						custom_5: null,
					},
				},
			};
		</script>
		<script src="https://8TbKqvot9rNud3j6Q.ay.delivery/client-v2.js" async></script>
		    <!-- Facebook Pixel Event Code -->
    <script type='text/javascript'>
        document.addEventListener( 'wpcf7mailsent', function( event ) {
        if( "fb_pxl_code" in event.detail.apiResponse){
          eval(event.detail.apiResponse.fb_pxl_code);
        }
      }, false );
    </script>
    <!-- End Facebook Pixel Event Code -->
    <div id='fb-pxl-ajax-code'></div>	<div class="adhesion bottom">
		<div class="close">&#10006;</div>
		<div class="ad-container">
			<!-- Ad Tag: ad-tag-adhesiondesktop -->
<div id="ad-tag-adhesiondesktop" class="cda-ad" data-adunit="/4052,1110987598/Moguldom/desktop" data-adsizes='{"desktop":[[1,1],[7,7],[320,50],[728,90],[320,100],[300,250]],"mobile":[]}' data-adoutofpage="" data-targeting='{"pos":"anchor"}'></div>		</div>
	</div>
	<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='modal-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.25' type='text/css' media='all' />
<link rel='preload' as='style' onload='this.onload=null;this.rel="stylesheet"' id='asp-default-style-css'  href='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/stripe-payments/public/views/templates/default/style.css?ver=2.0.60' type='text/css' media='all' />
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/moguldom.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' id='mashsb-js-extra'>
/* <![CDATA[ */
var mashsb = {"shares":"77","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/moguldom.com\/406574\/where-you-at-rick-ross-tells-crypto-and-metaverse-investors-to-show-him-all-that-fake-rich-money\/","title":"Where+You+At%3F+Rick+Ross+Tells+Crypto+And+Metaverse+Investors+To+Show+Him+%E2%80%98All+That+Fake+Rich+Money%E2%80%99","image":"https:\/\/moguldom.com\/wp-content\/uploads\/2022\/05\/915-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg","desc":"Not a day seems to go by lately without a news story about a crypto investor claiming to rake in millions of dollars but hip-hop mogul Rick Ross isn\u2019t buying it.\n\n\n\nRoss posted a video on \u2026","hashtag":"","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"9f4f501a6d","postid":"406574","servertime":"1651752670","ajaxurl":"https:\/\/moguldom.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' id='smw-plugin-main-js-extra'>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</script>
<script type='text/javascript' id='stripe-handler-ng-js-extra'>
/* <![CDATA[ */
var wpASPNG = {"iframeUrl":"https:\/\/moguldom.com\/asp-payment-box\/","ppSlug":"asp-payment-box","prefetch":"0","ckey":"9e4f7828861dc18db1af129585ecb53c","aspDevMode":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/stripe-payments/public/assets/js/stripe-handler-ng.js?ver=2.0.60' id='stripe-handler-ng-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/moguldom.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"51c3ccd8f8","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' id='mashnet-js-extra'>
/* <![CDATA[ */
var mashnet = {"body":"Check out this article: ","subject":"Check out this site","pinterest_select":"1","pinterest_image":"https:\/\/moguldom.com\/wp-content\/uploads\/2022\/05\/1200-Where-You-At-Rick-Ross-Tells-Crypto-And-MetaVerse-Investors-To-Show-Him-All-That-Fake-Rich-Money.jpg","pinterest_desc":"Not a day seems to go by lately without a news story about a crypto investor claiming to rake in millions of dollars but hip-hop mogul Rick Ross isn\u2019t buying it.\n\n\n\nRoss posted a video on \u2026"};
/* ]]> */
</script>
<script type='text/javascript' id='moengage-js-extra'>
/* <![CDATA[ */
var moengage_event_track = {"type":"post-single","post_id":"406574","categories":"google-news,hiphop","tags":"crypto-investors,crypto-millionaires,hip-hop-artists,hiphopme,metaverse,rick-ross","published_date":"2022\/05\/05"};
/* ]]> */
</script>
<script type='text/javascript' src='//c.amazon-adsystem.com/aax2/apstag.js' id='apstag-js'></script>
<script type='text/javascript' src='https://cdn.pubwise.io/script/900048b6-85d4-4685-97a2-02f77406e814/v1/pre_pws.js?type=default&#038;ver=5.9.3' id='pubwise-pre-js'></script>
<script type='text/javascript' src='https://cdn.pubwise.io/script/900048b6-85d4-4685-97a2-02f77406e814/v1/pws.js?type=default' id='pubwise-js'></script>
<script type='text/javascript' id='mmg-advertising-dfp-js-extra'>
/* <![CDATA[ */
var mmg_advertising_config = {"lazyload":"1","disableInitialLoad":"","additionalTargeting":{"postID":"406574","category":["google-news","hiphop","post"],"tag":["crypto-investors","crypto-millionaires","hip-hop-artists","hiphopme","metaverse","rick-ross"]}};
/* ]]> */
</script>
<div id="fb-root"></div><script src='https://stats.wp.com/e-202218.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'62301595',post:'406574',tz:'-4',srv:'moguldom.com'} ]);
	_stq.push([ 'clickTrackerInit', '62301595', '406574' ]);
</script>
		<script src="https://cz4u546tk1qjrndk9vowv1sz-wpengine.netdna-ssl.com/wp-content/plugins/promising-loader/script-loader.js?1620955303" defer></script>
		<script>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</script>
		</body>
</html>
